Insane browser CPU use, makes laptop freeze

I seem to be having a problem with browsers using a lot of cpu and thus freezing the computer temporarily.

On debian 7 this started to happen with iceweasel, so i switched to chromium. Then after a period of blissful speed surfing, then chromium went slow too. Other options would be to use midori or quzilla, but what’s interesting is that i had hoped upgrading to debian 8 would disappear the problem and it hasn’t.

From reading around the internets, people were suggesting it’s not necessarily the browser but the desktop environment, so i tried switching from the default (gnome?) to LXDE, choosing this particular environment since it’s alleged to be good for the asus eee (tips).

However, the problems continue as you can see from the screenshot. What’s good is that the LXDE setup makes it much easier to track the problem, with the graphical CPU usage monitor display bottom right. I’m also using top that’s what is in the screenshot (open a terminal, type top).

This is a fresh debian 8 install so the machine is totally uncluttered. It seems bizarre a browser is taking up so much CPU (143% if you look at the screenshot above when i tried to open 3 tabs at once on iceweasel). And this problem was generated with only a few tabs open, trying to open two more.

I don’t yet have an answer on this, so research continues.

Advertisements

Upgrade debian from wheezy to jessie

This process took me a long time (days in preparation!), but it’s good to do it right.

What i wanted to do was upgrade my asus eee laptop from debian 7 to 8 (wheezy to jessie), so i read around the topic a lot, using google searches and of course the debian instructions, which can sometimes be quite verbose but also have a lot of good stuff. In addition there’s specific instructions for the asus eee.

For the upgrade itself i followed the excellent clear instructions at howtoforge

It took a whole afternoon, the “apt-get upgrade” alone took an hour, much longer than i had read.

At a certain point i got this horrifying screen:

problem1

So i needed to go to the debian forums to ask for help about that but ultimately it worked out fine and everything seems to be in order.

Now running Jessie!

As a last point. it shouldn’t need saying but remember to back up all valuable documents!!! This would for me include gpg keys, emails, pictures, films,  writing, bookmarks (chromium, iceweasel, midori), zotero,  passwords and so on. If things had gone to shit (as at a certain point it seemed like it was) at least i still had everything saved on an external hard drive and ready to be reinstalled.